POJ 3253 — Fence Repair

Description

Farmer John wants to repair a small length of the fence around the pasture. He measures the fence and finds that he needs N (1 ≤ N ≤ 20,000) planks of wood, each having some integer length Li (1 ≤ Li ≤ 50,000) units. He then purchases a single long board just long enough to saw into the N planks (i.e., whose length is the sum of the lengths Li). FJ is ignoring the “kerf”, the extra length lost to sawdust when a sawcut is made; you should ignore it, too.

FJ sadly realizes that he doesn’t own a saw with which to cut the wood, so he mosies over to Farmer Don’s Farm with this long board and politely asks if he may borrow a saw.

Farmer Don, a closet capitalist, doesn’t lend FJ a saw but instead offers to charge Farmer John for each of the N-1 cuts in the plank. The charge to cut a piece of wood is exactly equal to its length. Cutting a plank of length 21 costs 21 cents.

Farmer Don then lets Farmer John decide the order and locations to cut the plank. Help Farmer John determine the minimum amount of money he can spend to create the N planks. FJ knows that he can cut the board in various different orders which will result in different charges since the resulting intermediate planks are of different lengths.

Input

Line 1: One integer N, the number of planks
Lines 2..N+1: Each line contains a single integer describing the length of a needed plank

Output

Line 1: One integer: the minimum amount of money he must spend to make N-1 cuts

Sample Input

3
8
5
8

Sample Output

34

Hint

He wants to cut a board of length 21 into pieces of lengths 8, 5, and 8.
The original board measures 8+5+8=21. The first cut will cost 21, and should be used to cut the board into pieces measuring 13 and 8. The second cut will cost 13, and should be used to cut the 13 into 8 and 5. This would cost 21+13=34. If the 21 was cut into 16 and 5 instead, the second cut would cost 16 for a total of 37 (which is more than 34).

题目链接

http://poj.org/problem?id=3253

题目翻译

农夫约翰为了修理栅栏,要将一块很长的木板切割成N块。准备切成的木板长度为L1,L2,L3……LN,未切割前木板的长度恰好为切割后木板长度的总和。每次切断木板时,需要的开销为这块木板的长度。请求出按照目标要求将木板切割完的最小开销是多少?例如长度为21的木板切割成长度为13和8,开销为21;把长度为13的木板切割成5和8,则开销为13,所以将长度为21的木板切割成8,5,8的三块,开销是34.
1 <= N <= 20000,0 <= Li <=50000

输入

第一行仅一个正整数N,第二行有N个正整数,两两之间用一个空格分隔。

输出

符合题目要求的一个正整数

题目分析

得到最终的一块木板的开销为:木板的长度 × 所需的切割次数
因此,最优的切割方法就是令短木板所需的切割次数多,长木板所需的切割次数少。
类似于最优二叉树。
构造一个优先队列,先将所有木板的长度放进去。每次取最小的两个数,将两数之和SUM放进队列,总开销加上SUM。直到队列中只有一个数字,就可以break了。
相当于模拟了用分散的木板合并成为整块木板的过程。
另外,使用 int 是不行的,因为在木板数量比较多时,总开销远大于整块木板的长度。

AC代码

#include <iostream>
#include <algorithm>
#include <queue>
#include <vector>
using namespace std;

priority_queue<long long, vector<long long>, greater<long long> /**/> q;

int main()
{
    int n, i, l;
    long long ans = 0;
    cin >> n;
    for (i = 0; i < n; i++)
    {
        cin >> l;
        q.push(l);
    }
    while (q.size() > 1)
    {
        long long x = q.top();
        q.pop();
        long long y = q.top();
        q.pop();
        q.push(x + y);
        ans += x + y;
    }
    cout << ans << endl;
    return 0;
}

发表评论

电子邮件地址不会被公开。 必填项已用*标注

开始在上面输入您的搜索词,然后按回车进行搜索。按ESC取消。

返回顶部