POJ 3069 — Saruman’s Army

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = −1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

题目链接

http://poj.org/problem?id=3069

题目翻译

直线上有N个点。点 i 的位置是Xi.从这N个点中选择若干个,给它们加上标记。对每一个点,其距离为R以内的区域里必须有带有标记的点(自己本身带有标记的点,可以认为与距离为0的地方有一个带有标记的点)。在满足这个条件的情况下,希望能为尽可能少的点添加标记。请问至少要有多少点被加上标记?
(1 ≤ n ≤ 1000,0 ≤ R ≤ 1000,0 ≤ xi ≤ 1000)

题目分析

先将所有点从小到大排序。
采用以下策略:
1. 记第一个点为left
2. 在点left右侧找到最后一个距离点left不大于r的点p
3. 在点p放置标记,ans++
4. 在点p右侧找到第一个距离点p大于r的点left
5. 回到第2步

AC代码

#include <iostream>
#include <algorithm>
using namespace std;

int main()
{
    int n, r, x[1005], i, ans, left;
    while (cin >> r >> n)
    {
        ans = 0;
        if (n == -1 && r == -1)
            break;
        for (i = 0; i < n; i++)
            cin >> x[i];
        sort(x, x + n);
        i = 0;
        while (i < n)
        {
            ans++;
            left = x[i++]; //left表示没有被覆盖的最左边的点
            for (; i < n; i++)
                if (x[i] - left > r)
                    break;
            int p = x[i - 1];              //被标记的点
            while (i < n && x[i] <= p + r) //一直向右前进直到距p的距离大于R的点
                i++;
        }
        cout << ans << endl;
    }
    return 0;
}

发表评论

电子邮件地址不会被公开。 必填项已用*标注

开始在上面输入您的搜索词,然后按回车进行搜索。按ESC取消。

返回顶部