PAT (Advanced Level) Practice 1008 Elevator

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41

题目大意

有一个电梯初始在0层,每上一层花6秒,每下一层花4秒,每次停留5秒。现在给出电梯的需求序列,求电梯完成这些任务需要的总时间。

题目分析

需求分三种,向上、向下、不动。记录当前电梯所在的楼层,然后分类进行处理即可。注意不动的这种情况也需要停留,要加上5秒。

AC代码

#include <bits/stdc++.h>
using namespace std;
int main()
{
    int n, x, current = 0, ans = 0;
    cin >> n;
    while (n--)
    {
        cin >> x;
        if (current < x)
            ans += 6 * (x - current);
        else if (current > x)
            ans += 4 * (current - x);
        ans += 5;
        current = x;
    }
    cout << ans << endl;
    return 0;
}

发表评论

电子邮件地址不会被公开。 必填项已用*标注

开始在上面输入您的搜索词,然后按回车进行搜索。按ESC取消。

返回顶部